POJ---2828 Buy Tickets

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 15846   Accepted: 7893

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan

題意:N個人買票,每個人都有一個初始的位置,按照這個初始位置排序,且後一個人可以插前一個人的隊(即如果前一個人佔用了後一個人的初始位置,則前一個人以後的整個隊伍向後移,讓出這個位置),求出最後整個隊列的位置情況
/**線段樹思路:
 *每個節點用來存儲當前節點以下的子樹總共還能存入幾個人
 *葉節點表示該位置是否有人,有則爲0,沒有則爲1
 *因爲如果從第一組數據開始則需要調整後面數據的位置,所以要倒着存入數據,這樣可以直接確定數據的位置
 *此時可以發現當需要放置的位置的值如果大於左子樹節點的值,則這個位置一定右子樹上
 *否則就在左子樹上
 */


#include<iostream>
#include<cstdio>
#include<cstring>
#define N 200005
using namespace std;

int Tree[N <<2];
int ans[N];//存儲數據順序

void PushUp(int rt)
{
    Tree[rt] = Tree[rt << 1] + Tree[rt << 1 | 1];
}
void build(int l,int r,int rt)//樹的初始狀態,葉節點都爲1
{
    int mid;
    if(l == r )
    {
        Tree[rt] = 1;
        return;
    }
    mid = (l + r) >> 1;
    build(l,mid,rt << 1);
    build(mid + 1,r,rt << 1 | 1);
    PushUp(rt);
}
void Update(int p,int v,int l,int r,int rt)//將v放入p位置上
{
    int  mid;
    if(l == r)
    {
        ans[l] = v;
        Tree[rt] = 0;
        return;
    }
    mid = (l + r) >> 1;
    if(p <= Tree[rt << 1])//如果p小於左子樹節點的值,則該數據在左子樹上
    {
        Update(p,v,l,mid,rt << 1);
    }
    else Update(p - Tree[rt << 1],v,mid + 1,r,rt << 1 | 1);
    PushUp(rt);
}

int main()
{
    int T;
    int i,j;
    int p[N],v[N];

    //freopen("FileIn.txt","r",stdin);
    //freopen("FileOut.txt","w",stdout);

    while(scanf("%d",&T) != EOF)
    {

        build(1,T,1);
        for(i = 1;i <= T;i++)scanf("%d%d",&p[i],&v[i]);
        //memset(ans,0,sizeof(ans));
        for(i = T;i >= 1;i--) Update(p[i] + 1,v[i],1,T,1);//題目給定初始位置是p之後,所以這裏要加1
        for(j = 1;j <= T;j++) printf("%d ",ans[j]);
        printf("\n");
    }
    //fclose(stdin);
    //fclose(stdout);

    return 0;
}











發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章