PAT-A-1040 Longest Symmetric String 【最長迴文串】

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

想法一:暴力枚舉,index從1開始size()-1結束,這時分爲兩種情況,一種是奇數對稱即index本身爲對稱軸,前後遍歷index-1,index +1。第二種是偶數對稱,前後便利index和index+1,然後根據條件輸出。奇數對稱2*counta+1;偶數對稱2*count.

有一個小細節,如果只有一個字符,那麼他也是對稱的,且答案爲1.

#include <iostream>
#include <string.h>
using namespace std;
int main(){
	int i=1,j,k,l,counta,countb,ans=0;
	char data[1024];
	fgets(data,1024,stdin);
	int size=strlen(data)-1;
	for(int i=0;i<size;i++){
		j=i-1;
		k=i+1;
		counta=0,countb=0;
		while(j>=0&&k<size){
			if(data[j]==data[k]){
				counta++;
				j--;
				k++;
			}else{
				break;
			}
		}
		l=i; 
		k=i+1;
		while(l>=0&&k<size){
			if(data[l]==data[k]){
				countb++;
				l--;
				k++;
			}else{
				break;
			}
		}
		ans=max(ans,max(2*counta+1,2*countb));
	}
	
	printf("%d\n",ans);
	return 0;
}

 


動態規劃 

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1000
using namespace std;
char s[MAX_N + 1];
int dp[MAX_N][MAX_N];
int main() {
    fgets(s, MAX_N + 1, stdin);
    int len = (int)strlen(s), res = 1;
    // 邊界
    for(int i = 0; i < len; i++){
        dp[i][i] = 1;
        if(i < len - 1 && s[i] == s[i + 1]){
            dp[i][i + 1] = 1;
            res = 2;
        }
    }
    
    // 遍歷L從3到len
    for(int L = 3; L <= len; L++){
        for(int i = 0, l = len - L + 1, j; i < l; i++){
            j = i + L - 1;
            if(s[i] == s[j] && dp[i + 1][j - 1] == 1){
                dp[i][j] = 1;
                res = L;
            }
        }
    }
    printf("%d", res);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章