PAT-A1023 Have Fun with Numbers 【散列】

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

Tips:

  • 題目說數字長度在20位一下,int(10),double(16)都不行,只能選擇使用string來保存了,按照字符一位一位去乘。
  • 想這樣一個問題,如果開頭的數字大於等於5,那麼結果位數一定多一位,一定輸出No,多出來的1位是‘1’,直接按照最高位小於等於4的方法一樣乘就行了。
  • map散列。char爲主鍵,出現次數爲值。
#include <iostream>
#include <string>
#include <map>
using namespace std;
map<char,int> data;
map<char,int> res;
void times(string s){
	bool go=false;        //最高位是否>=5
	if((s[0]-'0')>=5){
		printf("No\n");
		go=true;
	} 
	int flag=0;           //進位標誌
	for(int i=s.size()-1;i>=0;i--){
		int temp=(s[i]-'0');
		temp*=2;
		temp+=flag;
		if(temp>=10){
			temp-=10;
			flag=1;       //進位置1
		}
		else{
			flag=0;       //進位置0
		}
		s[i]=temp+'0';
		res[s[i]]+=1;
	}
	if(go){
		printf("1%s",s.c_str());
		return;
	}
	for(int j=0;j<s.size();j++){
		if(data[s[j]]==res[s[j]]) continue;
		else{
			printf("No\n");
			printf("%s",s.c_str());
			return;
		}
	}
	printf("Yes\n");
	printf("%s",s.c_str());

	
}
int main(){
	string num;
	cin>>num;
	for(int i=0;i<num.size();i++){
		data[num[i]]+=1;
	}
	times(num);
	return 0;
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章