PAT-A-1084 Broken Keyboard 【散列】

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

直接稱之爲散列不太合適,散列的變形吧,因爲他要求按檢測順序輸出,使用map散列的話,無法保證按序輸出 。

使用index標誌two的下標,遍歷one,不相同則判斷是否要輸出。否則i++,index++;

#include <iostream>
#include <string>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
int main(){
	string one,two;
	cin>>one>>two;
	map<char,int> res;
	int index=0;
	for(int i=0;i<one.size();i++){
		if(one[i]!=two[index]){
			if(65<=one[i]&&one[i]<=90){
				if(res[one[i]]==0) printf("%c",one[i]);
				res[one[i]]+=1;
				
			}
			else if(97<=one[i]&&one[i]<=122){
				if(res[one[i]-32]==0) printf("%c",one[i]-32);
				res[one[i]-32]+=1;
			}else{
				if(res[one[i]]==0) printf("%c",one[i]);
				res[one[i]]+=1;
			}
			continue;
		}
		index++;
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章