PAT-A-1054 The Dominant Color 【散列】

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

#include<iostream>
#include <map>
using namespace std;
int main(){
    map<int,int> data;
	int n,m;
	scanf("%d %d",&n,&m);
	int temp;
	while(m--){
		for(int i=0;i<n;i++){
			scanf("%d",&temp);
			data[temp]+=1;
		}
	}
	int max=-1;
	map<int,int>::iterator res;
	for(map<int,int>::iterator lt=data.begin();lt!=data.end();lt++){
		if(lt->second>max){
			max=t->second;
			res=lt;
		}
	}
	printf("%d",res->first);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章