PAT-A-1033 To Fill or Not to Fill 【貪心算法】

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: C​max​​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; D​avg​​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P​i​​, the unit gas price, and D​i​​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

一個很巧妙的思路,按照貪心算法,爲了達到路費最少,總是儘可能保障在油費最少的地方加滿油,否者郵箱裏的右剛好到下一站。

使用flag數組來標誌路程是否可達,初始化0表示都不可達,假如到了某一加油站加了油之後,從該站到杭州的距離開始到汽車能跑的距離置爲1;由於是貪心算法,即總是先滿足油費最低的加油站,給結構體按照油費遞增排序。然後按照上述思路開始給flag賦值。

遍歷輸出的時候,如果某一位置flag爲0,即無論加油,該位置不可達return掉 


#include <iostream>
#include <vector>
#include <string>
#include <stack>
#include <queue>
using namespace std;
struct station{               //保存加油站信息
	double price;
	int distance;
}sta[501];
bool cmp(const station s1,const station s2){
	return s1.price<s2.price;
}
int main(){
	int cap,dis,cost,num;
	int flag[30001]={0};         //!!!判斷是否可達
	double sum=0;
	scanf("%d %d %d %d",&cap,&dis,&cost,&num);
	for(int i=0;i<num;i++){
		scanf("%lf %d",&sta[i].price,&sta[i].distance);
	}
	sort(sta,sta+num,cmp);
	int max,cnt;
	for(int  j=0;j<num;j++){      //總是儘可能多加油,能加一箱肯定加一箱,用不了一箱,用多少 
                                  //加多少
		if(cap*cost+sta[j].distance>dis) max=dis-sta[j].distance;
		else max=cap*cost;
		cnt=0;
		for(int index=sta[j].distance;index<max+sta[j].distance;index++){
			if(flag[index]==0){
				flag[index]=1;
				cnt++;
			}
		}
		sum+=cnt/(cost*1.0)*sta[j].price;           //這一步很關鍵,cnt加出來的結果是里程
	}                                               //需要除以油耗
	for(int k=0;k<dis;k++){
		if(flag[k]==0){
			printf("The maximum travel distance = %.2lf\n", (double)k);
			return 0;
		}
	}
	printf("%.2lf\n",sum);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章