Digital Deletions - HDU 1404 博弈

Digital Deletions

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2191    Accepted Submission(s): 773


Problem Description
Digital deletions is a two-player game. The rule of the game is as following. 

Begin by writing down a string of digits (numbers) that's as long or as short as you like. The digits can be 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 and appear in any combinations that you like. You don't have to use them all. Here is an example:



On a turn a player may either:
Change any one of the digits to a value less than the number that it is. (No negative numbers are allowed.) For example, you could change a 5 into a 4, 3, 2, 1, or 0. 
Erase a zero and all the digits to the right of it.


The player who removes the last digit wins.


The game that begins with the string of numbers above could proceed like this: 



Now, given a initial string, try to determine can the first player win if the two players play optimally both. 
 

Input
The input consists of several test cases. For each case, there is a string in one line.

The length of string will be in the range of [1,6]. The string contains only digit characters.

Proceed to the end of file.
 

Output
Output Yes in a line if the first player can win the game, otherwise output No.
 

Sample Input
0 00 1 20
 

Sample Output
Yes Yes No No
 

題意:每次操作可以將一個0及其以後的數字去掉,或將一個1-9的數字降低其大小。移走最後一個數字的人獲勝,問先手勝負。

思路:暴力打表即可。

AC代碼如下:

#include<cstdio>
#include<cstring>
using namespace std;
int len;
bool win[1000000];
char s[10];
bool solve(int num)
{
    int i,j,k,k2=num,p=1;
    while(k2)
    {

        k=num/p%10;
        if(k==0)
        {
            if(!win[num/p/10])
              return true;
        }
        else
        {
            for(i=1;i<=k;i++)
            {
                if(!win[num-i*p] &&  !(i==k && k2/10==0))
                 return true;
            }

        }
        k2/=10;
        p*=10;
    }
    return false;
}
int main()
{
    int i,j,k;
    win[0]=1;
    for(i=1;i<1000000;i++)
       if(solve(i))
         win[i]=1;
    while(~scanf("%s",s+1))
    {
        if(s[1]=='0')
        {
            printf("Yes\n");
            continue;
        }
        len=strlen(s+1);
        k=0;
        for(i=1;i<=len;i++)
           k=k*10+s[i]-'0';
        if(win[k])
          printf("Yes\n");
        else
          printf("No\n");
    }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章