POJ2891 Strange Way to Express Integers(解多元線性同餘方程)

Strange Way to Express Integers
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 11289   Accepted: 3482

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31


Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.


題目大意:

選擇a1,a2....ak,對於某個整數m分別對ai求餘對應整數ri,現在已知a1,a2,....ak,以及整數對(ai,ri),求非負整數m的值,若有多個m,輸出最小的一個。

解題思路:
容易列出方程 m % ai = ri,可以轉化爲同餘方程 m ≡ ri (mod ai),接着套用求解多元線性同餘方程的模版即可。

AC代碼:

#include<iostream>
#include<cstdio>
#include<iostream>

using namespace std;

typedef long long ll;

void ex_gcd(ll a,ll b,ll &d,ll &x,ll &y)
{
    if(!b)
    {
        x = 1,y = 0,d = a;
    }
    else
    {
        ex_gcd(b,a%b,d,y,x);
        y -= x * (a / b);
    }
}

int main()
{
    long long i,n,a1,r1,a2,r2,a,b,c,d,x0,y0;
    while(scanf("%lld",&n) != EOF)
    {
        bool ifhave = 1;
        scanf("%lld%lld",&a1,&r1);
        for(i=1;i<n;i++)
        {
            scanf("%lld%lld",&a2,&r2);
            a = a1,b = a2,c = r2 - r1;
            ex_gcd(a,b,d,x0,y0);
            if(c % d != 0)
            {
                ifhave = 0;
            }
            int t = b / d;
            x0 = (x0 * (c / d) % t + t) % t;
            r1 = a1 * x0 + r1;
            a1 = a1 * (a2 / d);
        }
        if(!ifhave)
        {
            printf("-1\n");
            continue;
        }
        printf("%lld\n",r1);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章