POJ 2407 Relatives(歐拉函數)

Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12422   Accepted: 6043

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

歐拉函數:

歐拉函數p(n)指不超過n且與n互素的正整數的個數,其中,n是一個正整數,歐拉函數的性質:它在整數n上的值等於對n進行素因子分解後,所有的素數冪上的歐拉函數之積。


題目大意:

給出一個正整數n,小於n且和n互素的正整數有多少個?

解題思路:

直接運用歐拉函數模版即可.

AC代碼:

#include<iostream>

using namespace std;

int phi(int n)
{
	int rea = n;
	for(int i=2;i * i <= n;i++)
	{
		if(n % i == 0)
		{
			rea = rea - rea / i;
			do
			n /= i;
			while(n % i == 0);
		}
	}	
	if(n > 1)
	{
		rea = rea - rea / n;
	}
	return rea;
}

int main()
{
	int m;
	while(scanf("%d",&m) != EOF && m)
	{
		int res = phi(m);
		printf("%d\n",res);
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章