HDU 3292(No more tricks, Mr Nanguo 佩爾方程矩陣快速冪求解)

No more tricks, Mr Nanguo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 298    Accepted Submission(s): 188


Problem Description
Now Sailormoon girls want to tell you a ancient idiom story named “be there just to make up the number”. The story can be described by the following words.
In the period of the Warring States (475-221 BC), there was a state called Qi. The king of Qi was so fond of the yu, a wind instrument, that he had a band of many musicians play for him every afternoon. The number of musicians is just a square number.Beacuse a square formation is very good-looking.Each row and each column have X musicians.
The king was most satisfied with the band and the harmonies they performed. Little did the king know that a member of the band, Nan Guo, was not even a musician. In fact, Nan Guo knew nothing about the yu. But he somehow managed to pass himself off as a yu player by sitting right at the back, pretending to play the instrument. The king was none the wiser. But Nan Guo's charade came to an end when the king's son succeeded him. The new king, unlike his father, he decided to divide the musicians of band into some equal small parts. He also wants the number of each part is square number. Of course, Nan Guo soon realized his foolish would expose, and he found himself without a band to hide in anymore.So he run away soon.
After he leave,the number of band is Satisfactory. Because the number of band now would be divided into some equal parts,and the number of each part is also a square number.Each row and each column all have Y musicians.
 

Input
There are multiple test cases. Each case contains a positive integer N ( 2 <= N < 29). It means the band was divided into N equal parts. The folloing number is also a positive integer K ( K < 10^9).
 

Output
There may have many positive integers X,Y can meet such conditions.But you should calculate the Kth smaller answer of X. The Kth smaller answer means there are K – 1 answers are smaller than them. Beacuse the answer may be very large.So print the value of X % 8191.If there is no answers can meet such conditions,print “No answers can meet such conditions”.
 

Sample Input
2 999888 3 1000001 4 8373
 

Sample Output
7181 600 No answers can meet such conditions
 

Author
B.A.C
 

Source
 

題目大意:

轉化爲方程等價於求方程X^2 - N * Y ^ 2 = 1.

解題思路:

若N是完全平方數,則肯定無解,否則用暴力法求出方程的特解,然後根據佩爾方程矩陣快速冪求法得解。


AC代碼:

#include<iostream>
#include<cmath>
using namespace std;

int n;
int x,y;
typedef long long ll;
const int maxn = 4;
const int mod = 8191;

typedef struct
{
    int m[maxn][maxn];    
}Matrax;

Matrax a,per;

void sovle() //暴力法求特解 ,x,y爲特解 
{
    y = 1;
    while(1)
    {
        x = (ll)sqrt(n * y * y  + 1);
        if(x * x - n * y * y == 1)
        {
            break;
        }
        y++;
    }
}

void init() //矩陣快速冪初始化 
{
    int i,j;
    a.m[0][0] = x % mod;
    a.m[0][1] = n * y % mod;
    a.m[1][0] = y % mod;
    a.m[1][1] = x % mod;
    for(i=0;i<2;i++)
    {
        for(j=0;j<2;j++)
        {
            per.m[i][j] = (i == j);
        }
    }
}

Matrax multi(Matrax a,Matrax b) //矩陣乘法 
{
    Matrax c;
    int k,i,j;
    for(i=0;i<2;i++)
    {
        for(j=0;j<2;j++)
        {
            c.m[i][j] = 0; //初始化 
            for(k=0;k<2;k++)
            {
                c.m[i][j] += a.m[i][k] * b.m[k][j];
            }
            c.m[i][j] %= mod;
        }
    }
    return c;
}

Matrax power(int k) //矩陣乘方 
{
    Matrax p,ans = per;
    p = a;
    while(k)
    {
        if(k & 1)
        {
            ans = multi(ans,p);
            k--;    
        }    
        k /= 2;
        p = multi(p,p);
    }    
    return ans;
}

int main()
{
    int k;
    //freopen("1.txt","r",stdin);
    while(scanf("%d%d",&n,&k) != EOF)
    {
        int yi = sqrt(n + 0.0); 
        if(yi * yi == n) //完全平方數不滿足使用佩爾方程 
        {
            printf("No answers can meet such conditions\n");
            continue;
        }
        sovle(); //求一組特解x,y 
        init(); //初始化矩陣快速冪 
        a = power(k-1); //k - 1次方 
        x = (a.m[0][0] * x % mod + a.m[0][1] * y % mod) % mod; //求x 
        printf("%d\n",x);    
    } 
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章