Hdu1164(Eddy's research I 因子分解)

Eddy's research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7629    Accepted Submission(s): 4636


Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
11 9412
 

Sample Output
11 2*2*13*181
 

解題思路:

數據範圍比較小,可應用試除法進行整數分解.

AC代碼:

#include<iostream>
#include<cmath>
using namespace std;

const int maxn = 10001;

void divide(int n)
{
    int i,ct = 0,factor[maxn];
    for(i=2;i<=sqrt(n+0.0);i++)
    {
        while(n % i == 0)
        {
            ct++;
            factor[ct] = i;
            if(ct == 1)
            {
                printf("%d",factor[ct]);
            }
            else
            {
                printf("*%d",factor[ct]);
            }
            n /= i;
        }
    }
    if(n != 1)
    {
        ct++;
        factor[ct] = n;
        //cout<<"111"<<endl;
        if(ct == 1)
        {
            printf("%d",factor[ct]);
        }
        else
        {
            printf("*%d",factor[ct]);
        }
    } 
}

int main()
{
    int m;
    while(scanf("%d",&m) != EOF)
    {
        divide(m);
        printf("\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章