PAT-A-1044 Shopping in Mars 【二分查找】 【前缀和】

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解题思路
利用二分查找
1.将输入的数组A依次求和得到数组sum,这是sum数组递增
2.由于sum[i]表示1~i个元素之和,因此sum[j]-sum[i-1]代表i到j的和,且由于sum[j]-sum[i-1] = M 转化为查找sum[j] = sum[i-1]+M;
3.第一次遍历求出大于等于M的最接近M的nears
4.第二次遍历找出那些值恰好为nears的方案并输出.
————————————————
 


#include <iostream>
#include <algorithm>
using namespace std;
int s[100010];                 //保存前缀和,S[i]纪录从1开始到i的和
int main(){
    int x,y,neary=100000010;
    cin>>x>>y;
    s[0]=0;                    //数组从1开始
    for(int i=1;i<=x;i++){
        cin>>s[i];
        s[i]+=s[i-1];           
    }
    for(int i=1;i<=x;i++){  //枚举左端点
        int j=lower_bound(s+i,s+x+1,s[i-1]+y)-s;      //lower_bound函数,见函数解析
        if(s[j]-s[i-1]==y){                           //前闭后开,所以右侧加了1
            neary=y;                                  //找到break就行
            break;
        }
        else if(s[j]-s[i-1]>=y && s[j]-s[i-1]<neary)  //有大于y的解并小于neary就更新neary
            neary=s[j]-s[i-1];                        
    }
    for(int i=1;i<=x;i++){
        int j=lower_bound(s+i,s+x+1,s[i-1]+neary)-s;  //找出所有等于neary的区间
        if(s[j]-s[i-1]==neary)
            cout<<i<<"-"<<j<<'\n';
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章