hdu-1074 Doing Homework(狀態壓縮DP)

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6037    Accepted Submission(s): 2566


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 
又是啃了將近三個小時,才自己把代碼敲出來,自己代碼寫的比較爛(懶),也沒寫註解,

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define M 100000
using namespace std;
struct statue
{
int reduce,pre,cost;
}dp[M];
struct subject
{
char name[111];
int cost,deadline;
}sub[20];

void output(int i)
{
if(dp[i].pre==-1) return;
output(dp[i].pre);
int a=i&~dp[i].pre,bit=0;
while(a!=0)
{
bit++;
a/=2;
}
cout<<sub[bit-1].name<<endl;
}

int main(int argc, char *argv[])
{
int t,n,i,j;
cin>>t;
while(t--)
{
cin>>n;
for(i=0;i<n;i++)
{
scanf("\n%s%d%d",sub[i].name,&sub[i].deadline,&sub[i].cost);
}
for(i=0;i<M;i++) dp[i].reduce=9999999;
const int N=(int)(pow(2.0,n)-1);
dp[0].pre=-1;dp[0].reduce=0;dp[0].cost=0;
for(i=1;i<=N;i++)
{
int bit=0,ii=i;
while(ii!=0)
{
bit++;
ii/=2;
}
for(j=0;j<bit;j++)
{
if(i&(1<<j))
{
dp[i].cost=dp[i&~(1<<j)].cost+sub[j].cost;
int r,jj;
if(dp[i].cost>sub[j].deadline)
r=dp[i&~(1<<j)].reduce+dp[i].cost-sub[j].deadline;
else r=dp[i&~(1<<j)].reduce;
if(r<dp[i].reduce)
{
dp[i].reduce=r;
dp[i].pre=i&~(1<<j);
jj=j;
}
else if(r==dp[i].reduce&&strcmp(sub[j].name,sub[jj].name)==1)
{
dp[i].reduce=r;
dp[i].pre=i&~(1<<j);
jj=j;
}
}
}

}
cout<<dp[N].reduce<<endl;
output(N);
/*for(i=0;i<=N;i++)
{
cout<<dp[i].pre<<" "<<dp[i].cost<<" "<<dp[i].reduce<<endl;
}*/
}
return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章