POJ 1836 Alignment 變形的LIS

Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 15323   Accepted: 4974

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source


題意:最少去掉這個隊列中的多少個士兵後使得每個士兵都可以看到最左邊或者最右邊的士兵,一個士兵能看到另一個士兵需要這兩個士兵之間的士兵的身高小於該士兵;當存在兩個很高的士兵在中間,他們的身高之間的關係任意就可以了;能把題意弄明白了基本就不會錯那麼多次了Orz;

思路:把題意真正弄懂了,就相當於裸的LIS,不過你要求兩次LIS,在把這兩次的LIS聯合起來求出最終的結果;

代碼:

#include<cstdio>  
#include<cstring>
#include <algorithm>
#include <cmath>
using namespace std;  
#define maxn 1111
#define inf 0x3f3f3f3f
typedef long long LL;
double d[maxn];
int dp1[maxn],dp2[maxn];
int main()  
{  
#ifdef CDZSC_June
	freopen("t.txt", "r", stdin);  
#endif  
	int n;
	while(~scanf("%d",&n))
	{	
		memset(dp1,0,sizeof(dp1));
		memset(dp2,0,sizeof(dp2));
		for(int i =0; i<n; i++)
		{
			scanf("%lf",&d[i]);
		}
		int max1; dp1[0] = 1;
		for(int i = 1; i<n; i++)
		{
			max1 = 0;
			for(int j = 0; j<i; j++)
			{
				if(d[i] > d[j]){
					max1 = max(max1,dp1[j]);
				}
			}
			dp1[i] = max1+1;
		}
		dp2[n-1] = 1;
		for(int i = n-2; i>=0; i--)
		{
			max1 = 0;
			for(int j = n-1; j>i; j--)
			{
				if(d[i] > d[j]){
					max1 = max(max1,dp2[j]);
				}
			}
			dp2[i] = max1+1;
		}
		max1 = 0;
		for(int i = 0; i<n; i++)
		{
			for(int j = i+1; j<n; j++){
				max1 =max(max1,dp1[i]+dp2[j]);
			}
		}
		printf("%d\n",n - max1);
	}
	return 0;  
}  


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章