SGU102——Coprimes (又見歐幾里得)

102. Coprimes

time limit per test: 0.5 sec.
memory limit per test: 4096 KB

For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N.  Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).

Input

Input file contains integer N.

Output

Write answer in output file.

Sample Input

9

 

Sample Output

6

 

對於給定的N(1<=N<=10000),求不大於N並與N互質的正整數的個數。

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<ctype.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<list>
using namespace std;
int gcd(int m,int n)
{
    return n==0?m:gcd(n,m%n);
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int count=0;
        for(int i=0;i<n;i++)
        {
            if(gcd(i,n)==1)
            count++;
        }
        printf("%d\n",count);
    }
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章