UVA - 10025 :The ? 1 ? 2 ? ... ? n = k problem

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

12

-3646397

Sample Output

7

2701

//首先不管k的正負性,因爲一個負值存在那樣的表達式的話一定相應的存在正值表達式。 其次,假設一直用的是加號定存在n使得sum=n*(n+1)/2>=k,而如果要變某個加號爲減號也必定先滿足上面的表達式,在這基礎上由於改變一個加號爲減號相當於在原表達式(+的表達式)的基礎上減去了兩倍的當前這個數,所以(sum-k)必須爲偶數。那個第一個遇到的滿足上面兩個條件的n是不是就是要求的,答案是肯定的。因爲(sum-k)肯定小於n*(n-1)/2。而這個差值肯定能由前面的n個數中的某幾個做差得到。事實上在2*(2*(n-1)/2)內的數都可以由做差得到。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

int main()
{
	int T,t=0,k,i;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&k);
		if(t>0)
			puts("");
		t++;
		k=abs(k);
		int sum=0;
		for(i=1;;i++)
		{
			sum+=i;
			if(sum>=k&&(sum-k)%2==0)
			{
				printf("%d\n",i);
				break;
			}
		}
	} 
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章