POJ 1019 數學

Number Sequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 36482   Accepted: 10525

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
 
#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
unsigned int a[31270]={0},s[31270]={0};
int main()
{
 a[1]=s[1]=1;
 for(int i=2;i<31270;i++)
    {
     a[i]=a[i-1]+(int)log10((double)i)+1;
        s[i]=s[i-1]+a[i];
 }
 int T=0;
 scanf("%d",&T);
 while(T--)
 {
  int n=0;
  scanf("%d",&n);
  int i=1;
  while(s[i]<n) i++;
  int pos=n-s[i-1];
  int tem=0;
  i=1;
  for(i=1;tem<pos;i++)
  {
   tem+=(int)log10((double)i)+1;
  }
  pos=tem-pos;
  printf("%d\n",(i-1)/(int)pow(10.0,pos)%10);
 }
 return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章