PAT 1103. Integer Factorization (30)

1103. Integer Factorization (30)

時間限制
1200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62+ 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

這道題我用DFS+剪枝來做,主要要解決的問題還是超時問題。我們可以事先把各個數的各個次方求出來並保存在數組中,這樣一來就不用在後面的DFS中反覆計算,以節約時間。並且根據題意分析,N<=400, 1<P<=7,所以實際需要事先求的數並不多,用pow()函數可以解決,不會超時。

代碼如下: 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
int N,K,P;
int fact[21][8]={-1};
int limit[21] = {0,8,8,6,5,4, 4,4,3,3,3, 3,3,3,3,3, 3,3,3,3,3};
vector<int> tmpAnswer;
vector<vector<int> > allAnswer;
void dfs(int startPos, int sum, int count){
	for(int i = startPos; fact[i][P] > 0; i++){
		int sumTmp = sum + fact[i][P];
		if(sumTmp > N)
			return;
		if(count == K && sumTmp < N)
			continue;
		if(count == K && sumTmp == N){
			tmpAnswer.push_back(i);
			allAnswer.push_back(tmpAnswer);
			tmpAnswer.pop_back();
			return;
		}
		tmpAnswer.push_back(i);
		dfs(i,sumTmp,count+1);
		tmpAnswer.pop_back();
	}
}
int cmp(const vector<int> a, const vector<int> b){
	int sumA = 0, sumB = 0;
	for(int i = 0; i < a.size(); i++){
		sumA += a[i];
		sumB += b[i];
	}
	if(sumA != sumB)
		return sumA > sumB;
	return a > b;
}
int main(void)
{
	for(int i = 1; i < 21; i++)
		for(int j = 2; j < limit[i]; j++){
			int tmp = pow(i,j);
			fact[i][j] = tmp;
		}
	cin>>N>>K>>P;
	dfs(1,0,1);
	if(allAnswer.size() <= 0){
		cout<<"Impossible"<<endl;
		return 0;
	}
	for(int i = 0 ; i < allAnswer.size(); i++)
		reverse(allAnswer[i].begin(),allAnswer[i].end());
	sort(allAnswer.begin(),allAnswer.end(),cmp);
	cout<<N<<" = "<<allAnswer[0][0]<<"^"<<P;
	for(int i = 1; i < allAnswer[0].size(); i++){
		cout<<" + "<<allAnswer[0][i]<<"^"<<P;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章