PAT 1101. Quick Sort (25)

1101. Quick Sort (25)

時間限制
200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CAO, Peng

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input: 
5
1 3 2 4 5
Sample Output:
3
1 4 5

這道題不難,用數組就可以解決,但關鍵就是不能超時,所以需要一點取巧的方法。

對於輸入的數據數組rawlist,正向遍歷時,針對每一個點,都可以記錄出它前面的點的最大值,因此把當前點與最大值做比較,如果當前點大那麼就認定這個點“符合了一半的規則”,於是可以用另一個數組leftCondition來記錄哪些點符合規則。

同樣的,逆向遍歷,可以找到前面的最小點,於是又可以判定“符合另一半規則的點”。

最後再總的遍歷一遍之前判定的結果leftCondition和rightCondition數組,就可以得到哪些點符合pivot。

代碼如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
int N;
int leftCondition[100001]={0},rightCondition[100001]={0},rawlist[100001];
int main(void)
{
	cin>>N;
	int leftMax = -1;
	for(int i = 0; i < N; i++){
		scanf("%d",&rawlist[i]);
		if(rawlist[i] > leftMax){
			leftCondition[i] = 1;
			leftMax = rawlist[i];
		}
	}
	int rightMin = rawlist[N-1];
	rightCondition[N-1] = 1;
	for(int i = N - 2; i >= 0; i--){
		if(rawlist[i] < rightMin){
			rightCondition[i] = 1;
			rightMin = rawlist[i];
		}
	}
	vector<int> result;
	for(int i = 0; i < N; i++)
		if(leftCondition[i] == 1 && rightCondition[i] == 1)
			result.push_back(rawlist[i]);
	sort(result.begin(),result.end());
	cout<<result.size()<<endl;
	if(result.size()>0)
		cout<<result[0];
	for(int i = 1; i < result.size(); i++){
		cout<<" "<<result[i];
	}
	cout<<endl;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章