PAT 1104. Sum of Number Segments (20)

1104. Sum of Number Segments (20)

時間限制
200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CAO, Peng

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4 
Sample Output:
5.00

這道題的坑點是要用double而不能用float。。另外計算的時候也不能嵌套for循環,不過這個算式推導並不難。

代碼如下: 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
int N;
vector<double> rawInput;
int main(void)
{
	cin>>N;
	rawInput.resize(N);
	for(int i = 0; i < N; i++)
		scanf("%lf",&rawInput[i]);
	double sum = 0;
	for(int i = 0; i < N; i++){
		sum += rawInput[i] * (i+1)*(N-i);
	}
	printf("%.2f",sum);
	return 0;
}

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章