POJ3624 Charm Bracelet

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31374   Accepted: 13954

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
    这道题是裸的01揹包,比较简单,核心是01揹包的状态转移方程,只要与动态规划相关,下意识就觉得很难,其实,弄明白核心之后,也挺简单的。


   思路:01揹包~

#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXN 5000
using namespace std;
 
int f[3*MAXN];  //状态数组
int d[MAXN];  //每个物品的价值
int w[MAXN];  //每个物品的重量
int N,M;
 
int main()
{
    scanf("%d%d",&N,&M);
    memset(f,0,sizeof(f));
    memset(d,0,sizeof(d));
    memset(w,0,sizeof(w));
    for(int i=1;i<=N;i++)
    {
        scanf("%d%d",&w[i],&d[i]);
    }
 
    for(int i=1;i<=N;i++)
    {
        for(int j=M;j>=w[i];j--)
        {
            f[j]=max(f[j],f[j-w[i]]+d[i]);//对于每个物品,取其 不放这个物品的价值或放这个物品后 中的最大值
                                        //,如果放,所能承受的容量减去放进去的物品的重量表示放进去了这个物品
        }
    }
    printf("%d\n",f[M]);
    return 0;
}
发布了50 篇原创文章 · 获赞 2 · 访问量 2万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章