POJ3628 Bookshelf2

Bookshelf 2
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9255   Accepted: 4189

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1
       題意:農夫約翰買了一個書架,但是書架的最高層牛們夠不着,牛們就把自己像疊羅漢那樣摞起來,總共有N頭牛,每頭牛的高度爲Hi,書架高度爲1<B<S,其中s爲所有牛身高的和,求出,這些牛摞起來的高度和與書架的高度的差的最小值。


     思路:還是01揹包,每次,用不用這頭牛的高度,求出所有的狀態,然後從第一個開始遍歷,找出最小的

代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
 
int main()
{
    int n,b;
    while(scanf("%d%d",&n,&b)!=EOF)
    {
        int hight[20],dp[1000050];//dp爲狀態數組
        int sum=0;
        memset(hight,0,sizeof(hight));
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&hight[i]);
            sum+=hight[i];
        }
        for(int i=0;i<n;i++)
        {
            for(int j=sum;j>=hight[i];j--)
            {
                dp[j]=max(dp[j],dp[j-hight[i]]+hight[i]);//狀態轉移方程
            }
        }
        for(int i=0;i<=sum;i++)
        {
            if(dp[i]>=b) {printf("%d\n",dp[i]-b);break;}//找出大於b的最小值,並輸出差
        }
    }
    return 0;
}

發佈了50 篇原創文章 · 獲贊 2 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章