PAT_1055: The World's Richest

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None
備註:題目很像一個數據庫查詢,對效率的要求比較高。剛開始先對age進行統計,再排序輸出,結果case 2超時;後直接對整個數組排序然後輸出,結果case 1超時最後AC的方法是:先對整個數組進行排序,然後統計各年齡的人數,過濾那些各年齡100名後的人(因爲M<=100,他們永遠不可能被輸出),用另一數組進行標記是否要放棄,最後遍歷該數組即可,節省了時間。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

#define MAXAGE 201
#define MAXPERSON 100000

typedef struct person
{
	char name[20];
	int age;
	int worth;
}PERSON;

PERSON Person_list[MAXPERSON];

int compare(const void *a,const void *b)
{
	PERSON *p1 = (PERSON *)a;
	PERSON *p2 = (PERSON *)b;

	if(p1->worth==p2->worth && p1->age==p2->age)
		return strcmp(p1->name,p2->name);
	if(p1->worth==p2->worth)
		return p1->age-p2->age;
	return p2->worth-p1->worth;
}

int main()
{
	int n,k;
	int m,Amin,Amax;
	int i,j;
	int ageCount[MAXAGE]={0};
	int output[MAXPERSON];

	scanf("%d %d",&n,&k);
	for(i=0;i<n;i++)
		scanf("%s %d %d",Person_list[i].name,&Person_list[i].age,&Person_list[i].worth);

	qsort(Person_list,n,sizeof(PERSON),compare);

	// count the number of people of each age and abandon those who are ranked after 100
	// flag the sorted array
	int bound = 0;
	for(i=0;i<n;i++)
	{
		if(++ageCount[Person_list[i].age]<=100)
			output[bound++]=i;
	}

	for(i=1;i<=k;i++)
	{		
		scanf("%d %d %d",&m,&Amin,&Amax);
		printf("Case #%d:\n",i);
		int countM=0;
		for(j=0;j<bound;j++)
		{
			PERSON p = Person_list[output[j]];
			if(p.age>=Amin && p.age<=Amax && countM<m)
			{
				printf("%s %d %d\n", p.name,p.age,p.worth);
				countM++;
			}
			if(countM==m)
				break;
		}
		if(countM==0)
			printf("None\n");
	}
		
	return 0;
}


發佈了58 篇原創文章 · 獲贊 0 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章