PAT_1051: Pop Sequence

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
備註: 用一個stack來模擬push和pop的過程即可。
#include<stdio.h>
#include<stack>
using namespace std;

bool IsPopSequence(int poplist[],int n,int m)
{
	stack<int> myStack;

	// use myStack to handle the pop sequence
	for(int push_num=1, i=0;push_num<=n+1 && i<n;)
	{
		if(myStack.empty() || myStack.top()!=poplist[i])
		{
			myStack.push(push_num++);
			if(myStack.size()>m)
				return false;
		}
		else
		{
			myStack.pop();
			i++;
		}
	}
	if(!myStack.empty())
		return false;
	return true;
}
int main()
{
	int M,N,K;
	int pop_list[1010];
	scanf("%d %d %d",&M,&N,&K);

	for(int i=0;i<K;i++)
	{		
		for(int j=0;j<N;j++)
			scanf("%d",&pop_list[j]);
		//check if it is a pop sequence
		if(IsPopSequence(pop_list,N,M))
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


發佈了58 篇原創文章 · 獲贊 0 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章