PAT_1016: Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
備註:用了map,把人名當key,此人的records數組作爲value,避免了sort人名,因爲在map中是按照key自動排序的(string類型剛好是按字典升序排的)。 然後把每個人的records根據時間sort一下,找到匹配的records算一下時間和費用就可以(算費用的過程有夠麻煩的)。還要注意的是如果某人沒有匹配的記錄則不用輸出任何東西!(題目中只保證了所有輸入中肯定有一對匹配的記錄,不保證每個人都有一對匹配的記錄)另外,剛開始一直沒A居然是因爲人名數組開太小了,char name[20]改成char name[50]就對了,我真是天雷滾滾,口吐無限髒話!
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<string>
using namespace std;

#define ONLINE 1
#define OFFLINE -1

int toll[24];
int n;

typedef struct record
{
	char name[50];
	int month;
	int day;
	int hour;
	int minute;
	int b_line;
}RECORD;

map<string, vector<RECORD>> myMap;
map<string, vector<RECORD>>::iterator iter;

//compare two records based on time
//returns true if r1 is earlier than r2
//otherwise returns false
bool compareRecords(RECORD r1, RECORD r2)
{
	if(r1.month<r2.month)
		return true;
	else if(r1.month>r2.month)
		return false;
	else
	{
		if(r1.day<r2.day)
			return true;
		else if(r1.day>r2.day)
			return false;
		else
		{
			if(r1.hour<r2.hour)
				return true;
			else if(r1.hour>r2.hour)
				return false;
			else
			{
				if(r1.minute<r2.minute)
					return true;
				else
					return false;
			}
		}
	}
}

//compute the toll for a call, complicated!
float ComputeToll(RECORD r1,RECORD r2)
{	
	int charge = 0;
	int totalmins = 0;
	int one_day_charge = 0;
	for(int i=0;i<24;i++)
		one_day_charge+=toll[i]*60;
	
	// because tolls are computed based on hour, we first compare hour
	if(r2.hour>r1.hour)
	{
		for(int i=r1.hour+1;i<r2.hour;i++)
		{
			charge+= toll[i]*60;
			totalmins+=60;
		}
		charge+=(60-r1.minute)*toll[r1.hour]+r2.minute*toll[r2.hour];
		totalmins+=(60-r1.minute)+r2.minute;
		charge+= (r2.day-r1.day)*one_day_charge;
		totalmins+=(r2.day-r1.day)*60*24;
	}
	else if(r2.hour==r1.hour)
	{
		charge+=(r2.minute-r1.minute)*toll[r1.hour];
		totalmins+=(r2.minute-r1.minute);
		charge+= (r2.day-r1.day)*one_day_charge;
		totalmins+=(r2.day-r1.day)*60*24;
	}
	else // r2.hour<r1.hour, two different days, r2.day>r1.day
	{
		charge+=(60-r1.minute)*toll[r1.hour];
		totalmins+=(60-r1.minute);
		for(int i=r1.hour+1;i<24;i++)
		{
			charge+= toll[i]*60;
			totalmins+=60;
		}
		for(int i=0;i<r2.hour;i++)
		{
			charge+= toll[i]*60;
			totalmins+=60;
		}
		charge+=r2.minute*toll[r2.hour];
		totalmins+=r2.minute;
		charge+=(r2.day-r1.day-1)*one_day_charge;
		totalmins+=(r2.day-r1.day-1)*60*24;
	}
	printf("%d $%.2f\n",totalmins,(float)charge/(float)100);
	return (float)charge/(float)100;
}

// pair the records for one person
void PairRecords(vector<RECORD> r_list)
{
	// sort the records by time
	sort(r_list.begin(),r_list.end(),compareRecords);

	vector<RECORD>::iterator v_iter;
	bool havePairs = false;	
	float amount = 0;

	for(v_iter = r_list.begin();v_iter != r_list.end(); v_iter++)
	{	
		RECORD r = *v_iter;
		if(r.b_line == ONLINE)
		{
			if((v_iter+1)!=r_list.end()) 
			{
				RECORD r_next = *(v_iter+1);
				if(r_next.b_line == OFFLINE) // find a pair
				{
					if(!havePairs) // note that a customer could have no paired records, then no output should be given
					{
						printf("%s %02d\n",r.name, r.month);
						havePairs = true;		
					}
					//compute the toll of the current call
					printf("%02d:%02d:%02d %02d:%02d:%02d ",r.day,r.hour,r.minute,r_next.day,r_next.hour,r_next.minute);
					float charge = ComputeToll(r,r_next);
					amount+=charge;
				}	
			}
		}		
	}
	if(havePairs)
		printf("Total amount: $%.2f\n",amount);
}

int main()
{
	for(int i=0;i<24;i++)
		cin>>toll[i];

	cin>>n;
	
	for(int i=0;i<n;i++)
	{
		RECORD r;
		cin>>r.name;
		scanf("%d:%d:%d:%d",&r.month,&r.day,&r.hour,&r.minute);
		string line;
		cin>>line;
		if(line=="on-line")
			r.b_line = ONLINE;
		else
			r.b_line = OFFLINE;		
		myMap[r.name].push_back(r);	
	}

	// pair the record for each person
	for(iter = myMap.begin();iter != myMap.end(); iter++)
	{
		
		vector<RECORD> r_list = iter->second;
		PairRecords(r_list);		
	}

	return 0;
}


發佈了58 篇原創文章 · 獲贊 0 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章