hdu-1018-Big Number-簡單數學

Link: http://acm.hdu.edu.cn/showproblem.php?pid=1018

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34113    Accepted Submission(s): 16119

Problem Description

  In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

Source

Asia 2002, Dhaka (Bengal)

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1013 1017 1016 1002 1071 

解釋

其實我們很容易想到 lg(n!)+1 即爲所求結果

Code

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
int n;
int main()
{
    int ans;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        long double res=log10(1);
        for(int i=2;i<=n;i++)
            res+=log10(i);
        ans=floor(res)+1;
        cout<<ans<<endl;
    }
    return 0;
}
發佈了37 篇原創文章 · 獲贊 6 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章