POJ Mayor's posters 2528(線段樹+離散化)

Mayor's posters
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 59647   Accepted: 17287

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source


題意:給定一些海報,可能相互重疊,告訴你每個海報的寬度(高度都一樣的)和先後疊放順序,問沒有被完全蓋住的有多少張?

海報最多10000張,但是牆有10000000塊瓷磚長,海報不會落在瓷磚中間。

分析:第一感覺線段樹,但是長度是10000000,開不了,那就得離散化了,之前沒接觸過離散化,上網上找了一點

在網上找了一點

通俗點說,離散化就是壓縮區間,使原有的長區間映射到新的短區間,但是區間壓縮前後的覆蓋關係不變。舉個例子:

有一條1到10的數軸(長度爲9),給定4個區間[2,4] [3,6] [8,10] [6,9],覆蓋關係就是後者覆蓋前者,每個區間染色依次爲 1 2 3 4。

現在我們抽取這4個區間的8個端點,2 4 3 6 8 10 6 9

然後刪除相同的端點,這裏相同的端點爲6,則剩下2 4 3 6 8 10 9

對其升序排序,得2 3 4 6 8 9 10

然後建立映射

2     3     4     6     8     9   10

↓     ↓      ↓     ↓     ↓     ↓     ↓

1     2     3     4     5     6     7

那麼新的4個區間爲 [1,3] [2,4] [5,7] [4,6],覆蓋關係沒有被改變。新數軸爲1到7,即原數軸的長度從9壓縮到6,顯然構造[1,7]的線段樹比構造[1,10]的線段樹更省空間,搜索也更快,但是求解的結果卻是一致的。

 

離散化時有一點必須要注意的,就是必須先剔除相同端點後再排序,這樣可以減少參與排序元素的個數,節省時間。

這個題的離散就是這樣,不過用了一個哈希,可以直接找到對應的點,不用再二分去找

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxx 11234
int ha[10000005];
int k[maxx<<4];//不知道爲什麼開4倍re
int ans;
struct node//記錄輸入的區間
{
    int ll,rr;
}q[maxx];
int cun[maxx<<1];
void up(int rt)
{
    if(k[rt]!=0)
    {
        k[rt<<1]=k[rt<<1|1]=k[rt];
        k[rt]=0;  //一開始等於0,後來他的上一級就又把他更新了
    }
}
void gengxin(int x,int y,int p,int l,int r,int rt)//每個區間都附上不同的值
{
    if(x<=l && r<=y)
    {
        k[rt]=p;
        return ;
    }
    up(rt);      //從下向上的更新
    int m=(l+r)>>1;
    if(x<=m)
    gengxin(x,y,p,lson);
    if(m<y)
    gengxin(x,y,p,rson);
}
void query(int l,int r,int rt)  //找有多少不同的值
{
    if(k[rt]!=0) //把每個點都遍歷一遍
    {
        if(!ha[k[rt]])
        {
            ans++;
            ha[k[rt]]=1;
        }
        return ;
    }
    if(l==r)return ;
    int m=(l+r)>>1;
    query(lson);
    query(rson);
}
int main()
{
    int n,m,i,j;
    int t;
    scanf("%d",&t);
    while(t--)
    {
    scanf("%d",&n);
    memset(ha,0,sizeof(ha));
    int top=1;
    for(i=1;i<=n;i++)
    {
        scanf("%d%d",&q[i].ll,&q[i].rr);
        if(!ha[q[i].ll]) {cun[top++]=q[i].ll;ha[q[i].ll]=1;}//把區間邊界無重複的存入數組
        if(!ha[q[i].rr]){cun[top++]=q[i].rr;ha[q[i].rr]=1;}
    }
    memset(k,0,sizeof(k));
    sort(cun+1,cun+top);//排序
    for(i=1;i<top;i++)  //把數據當下標,可以直接找出他是第幾大
    {
        ha[cun[i]]=i;
    }
    int x,y;
    int l=1,r=top;
   for(i=1;i<=n;i++)
   {
       x=ha[q[i].ll];
       y=ha[q[i].rr];
       gengxin(x,y,i,l,r,1);
   }
   ans=0;
   memset(ha,0,sizeof(ha));
   query(l,r,1);
   printf("%d\n",ans);
    }
    return 0;
}




發佈了74 篇原創文章 · 獲贊 48 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章