POJ Mayor's posters 2528(线段树+离散化)

Mayor's posters
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 59647   Accepted: 17287

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source


题意:给定一些海报,可能相互重叠,告诉你每个海报的宽度(高度都一样的)和先后叠放顺序,问没有被完全盖住的有多少张?

海报最多10000张,但是墙有10000000块瓷砖长,海报不会落在瓷砖中间。

分析:第一感觉线段树,但是长度是10000000,开不了,那就得离散化了,之前没接触过离散化,上网上找了一点

在网上找了一点

通俗点说,离散化就是压缩区间,使原有的长区间映射到新的短区间,但是区间压缩前后的覆盖关系不变。举个例子:

有一条1到10的数轴(长度为9),给定4个区间[2,4] [3,6] [8,10] [6,9],覆盖关系就是后者覆盖前者,每个区间染色依次为 1 2 3 4。

现在我们抽取这4个区间的8个端点,2 4 3 6 8 10 6 9

然后删除相同的端点,这里相同的端点为6,则剩下2 4 3 6 8 10 9

对其升序排序,得2 3 4 6 8 9 10

然后建立映射

2     3     4     6     8     9   10

↓     ↓      ↓     ↓     ↓     ↓     ↓

1     2     3     4     5     6     7

那么新的4个区间为 [1,3] [2,4] [5,7] [4,6],覆盖关系没有被改变。新数轴为1到7,即原数轴的长度从9压缩到6,显然构造[1,7]的线段树比构造[1,10]的线段树更省空间,搜索也更快,但是求解的结果却是一致的。

 

离散化时有一点必须要注意的,就是必须先剔除相同端点后再排序,这样可以减少参与排序元素的个数,节省时间。

这个题的离散就是这样,不过用了一个哈希,可以直接找到对应的点,不用再二分去找

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxx 11234
int ha[10000005];
int k[maxx<<4];//不知道为什么开4倍re
int ans;
struct node//记录输入的区间
{
    int ll,rr;
}q[maxx];
int cun[maxx<<1];
void up(int rt)
{
    if(k[rt]!=0)
    {
        k[rt<<1]=k[rt<<1|1]=k[rt];
        k[rt]=0;  //一开始等于0,后来他的上一级就又把他更新了
    }
}
void gengxin(int x,int y,int p,int l,int r,int rt)//每个区间都附上不同的值
{
    if(x<=l && r<=y)
    {
        k[rt]=p;
        return ;
    }
    up(rt);      //从下向上的更新
    int m=(l+r)>>1;
    if(x<=m)
    gengxin(x,y,p,lson);
    if(m<y)
    gengxin(x,y,p,rson);
}
void query(int l,int r,int rt)  //找有多少不同的值
{
    if(k[rt]!=0) //把每个点都遍历一遍
    {
        if(!ha[k[rt]])
        {
            ans++;
            ha[k[rt]]=1;
        }
        return ;
    }
    if(l==r)return ;
    int m=(l+r)>>1;
    query(lson);
    query(rson);
}
int main()
{
    int n,m,i,j;
    int t;
    scanf("%d",&t);
    while(t--)
    {
    scanf("%d",&n);
    memset(ha,0,sizeof(ha));
    int top=1;
    for(i=1;i<=n;i++)
    {
        scanf("%d%d",&q[i].ll,&q[i].rr);
        if(!ha[q[i].ll]) {cun[top++]=q[i].ll;ha[q[i].ll]=1;}//把区间边界无重复的存入数组
        if(!ha[q[i].rr]){cun[top++]=q[i].rr;ha[q[i].rr]=1;}
    }
    memset(k,0,sizeof(k));
    sort(cun+1,cun+top);//排序
    for(i=1;i<top;i++)  //把数据当下标,可以直接找出他是第几大
    {
        ha[cun[i]]=i;
    }
    int x,y;
    int l=1,r=top;
   for(i=1;i<=n;i++)
   {
       x=ha[q[i].ll];
       y=ha[q[i].rr];
       gengxin(x,y,i,l,r,1);
   }
   ans=0;
   memset(ha,0,sizeof(ha));
   query(l,r,1);
   printf("%d\n",ans);
    }
    return 0;
}




发布了74 篇原创文章 · 获赞 48 · 访问量 2万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章