zoj 3329 One Person Game 概率dp

One Person Game

Time Limit: 1 Second      Memory Limit: 32768 KB      Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698


題意:有三個骰子,分別有Die1,Die2,Die3 個面,每擲一次骰子,若三個面分別爲a,b,c,則計數器清零,否則計數器加上三個點數,當計數器大於n時結束,問結束時投擲骰子的期望。

思路:思路參考http://blog.csdn.net/morgan_xww/article/details/6775853,推得一手好公式,表示以前不知道還能這麼求期望。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int mod=1e9+7;
const int N=555;
double p[40],pa[N],pb[N];
int main(){
    int n,t,die1,die2,die3,a,b,c;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d%d%d%d%d",&n,&die1,&die2,&die3,&a,&b,&c);
        memset(p,0,sizeof(p));
        memset(pa,0,sizeof(pa));
        memset(pb,0,sizeof(pb));
        int dd=die1+die2+die3;
        double pp=1.0/(die1*die2*die3);
        for(int i=1;i<=die1;i++){
            for(int j=1;j<=die2;j++){
                for(int k=1;k<=die3;k++){
                    if(i==a&&j==b&&k==c)continue;
                        p[i+j+k]+=pp;
                }
            }
        }
        for(int i=n;i>=0;i--){
            pa[i]=pp;
            pb[i]=1;
            for(int j=3;j<=dd;j++){
                pa[i]+=pa[i+j]*p[j];
                pb[i]+=pb[i+j]*p[j];
            }
        }
    printf("%.10lf\n",pb[0]/(1-pa[0]));
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章