hdu 5001 Walk 概率dp 2014 ACM/ICPC Asia Regional Anshan Online

Walk

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 350    Accepted Submission(s): 228
Special Judge


Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.

The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.

If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.

T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
 

Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.

Your answer will be accepted if its absolute error doesn't exceed 1e-5.
 

Sample Input
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
 

Sample Output
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5017 5016 5015 5013 5012 
 

题意:求走d步不经过i点的概率。

思路:这题题解是矩阵快速幂的做法,但是概率dp也可以,dp[d][i]表示走d步到达i点的概率,每次排除一点,求所有点的概率和就是不经过该点的概率。求概率这种东西一般就是变换思维,比赛的时候思路没绕过来,就想不明白怎么求概率。

#include <iostream>
#include <stdio.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int mod=1e9+7;
const int N=52;
vector <int> vec[N];
int t,n,m,d,a,b;
double dp[10005][N],ans[N];
void init(){
    memset(ans,0,sizeof(ans));
    memset(vec,0,sizeof(vec));
    scanf("%d%d%d",&n,&m,&d);
        while(m--){
            scanf("%d%d",&a,&b);
            vec[a].push_back(b);
            vec[b].push_back(a);
        }
}
void solve(){
    for(int cas=1;cas<=n;cas++){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            dp[0][i]=1.0/n;
        dp[0][cas]=0;
        for(int i=1;i<=d;i++){
            for(int j=1;j<=n;j++){
                if(j==cas)continue;
                for(int k=0;k<vec[j].size();k++){
                    if(vec[j][k]==cas)continue;
                    dp[i][j]+=dp[i-1][vec[j][k]]/vec[vec[j][k]].size();
                }
            }
        }
        for(int i=1;i<=n;i++)
            ans[cas]+=dp[d][i];
    }
    for(int i=1;i<=n;i++)printf("%.8lf\n",ans[i]);
}
int main()
{
    scanf("%d",&t);
    while(t--){
        init();
        solve();
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章