Piggy-Bank—hdu1114完全揹包

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19651    Accepted Submission(s): 9975


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
給出揹包大小和物品大小與價值,求裝滿揹包時的最小价值;

二維寫法:

設dp[i][j]爲:在選擇第i種物品時,剛好裝滿大小爲j的揹包的最小价值

w[i]:第i中物品的大小

v[i]:第i種物品的價值

狀態轉移方程:當w[i]>j,即大小爲j的揹包裝不下一個第i種物品,則有: dp[i][j] = dp[i - 1][j];即第i種物品一個也不放

當w[i] <= j,即大小爲j的揹包能裝下至少一個第i種物品,則有:dp[i][j] = min(dp[i - 1][j],dp[i][j - w[i]] + v[i]]);即在 放入一個第i種物品和不放入i種物品中選擇一個最小值

這裏的第二種情況可能不太好理解,因爲從方程中看似乎只考慮了放入一個第i種物品的情況,但是要知道j是逐漸變大的,只要j的上限不止能放下一個第i種物品,就會逐漸疊加第i種物品的數量;

因爲是求最小值,所以數組的初始化除了dp[i][0]爲0之外都是INF

不能理解的手動畫一個表模擬一下好好體會過程

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x7ffffff
using namespace std;
int dp[500][10000];
int v[505];
int w[505];
int min_dp(int n,int b)
{
    for(int i = 0; i <= n; i++) {
        for(int j = 0;j <= b;j++){
            if(i == 0 && j != 0)
                dp[i][j] = INF;
            else if(i != 0&& j == 0)
                dp[i][j] = 0;
            else dp[i][j] =  INF;
        }
    }
    for(int i = 1;i <= n;i++)
    {
        for(int j = 1;j <= b;j++)
        {
            if(w[i] > j)
                dp[i][j] = dp[i - 1][j];
            else
               {
                   dp[i][j] =min(dp[i - 1][j],dp[i][j - w[i]] + v[i]);
               }
        }
    }
    return 0;
}

int main()
{
    int t,n,e,f,b;
    scanf("%d",&t);
    while(t--) {
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        memset(dp,0,sizeof(dp));
        scanf("%d%d%d",&e,&f,&n);
        b = f - e;
        for(int i =1 ; i<= n; i++) {
            scanf("%d%d",&v[i],&w[i]);
        }
        min_dp(n,b);
        if(dp[n][b] == INF) printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[n][b]);
    }
    return 0;
}
一維寫法:

設dp[i]爲恰好裝滿大小爲i的揹包實現的最小价值

狀態方程:如果w>i,即大小爲i的揹包裝不下當前的物品,則dp[i]揹包保持狀態不變;

如果w<=i,即大小爲i的揹包能裝下當前的物品,則有 : dp[i] = min(dp[i],dp[i - w] + v);即在 裝下當前物品和不裝當前物品中選擇一個最小值;

同二維寫法一樣,第二種情況會隨着i的變大而逐漸考慮加入多個當前物品的情況;

數組的初始化除0之外都爲INF

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x7ffffff
using namespace std;
int dp[10005];
int main()
{
    int t,n,e,f,cap,w,v;
    scanf("%d",&t);
    while(t--) {
        scanf("%d%d%d",&e,&f,&n);
        cap = f - e;
        for(int i = 1;i <=cap;i++){//只需要初始化cap大小的揹包
            dp[i] = INF;
        }
        dp[0] = 0;
        for(int j =1 ; j<= n; j++) {
            scanf("%d%d",&v,&w);
            for(int i = 1;i <= cap;i++){
                if(i >= w){
                    dp[i] = min(dp[i],dp[i - w] + v);
                }
            }
        }
        if(dp[cap] == INF) printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[cap]);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章