HDU 6047 Maximum Sequence【贪心】

题目来戳呀

Problem Description

Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: an+1…a2n. Just like always, there are some restrictions on an+1…a2n: for each number ai, you must choose a number bk from {bi}, and it must satisfy ai≤max{aj-j│bk≤j

Input

The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.

Output

For each test case, print the answer on one line: max{∑2nn+1ai} modulo 109+7。

Sample Input

4
8 11 8 5
3 1 4 2

Sample Output

27

Hint

For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9;
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

题意:

长度为n的a和b数列,想要将a后添加n个元素,添加的a数列满足ai ≤max(aj-j), j满足 bk ≤j<i,每个bk 只能拿一次求后添加的n个元素的和。

想法:

为了使新增的每一个ai 最大,应该保证i越小时,aj 越大,bk 越小,这样减数会越小。

所以我们先从后往前更新ai ,把越大的ai -i赋值给越小的i时的ai ,然后对b排序。
最后再取ai 时,拿ai 之前a中的最大值。

tips:
1.a,b数组开的时候要注意是开两倍,因为增加了n个元素
2.在最后取ai 的时候,取过的ai 也要减去i,当成已知的a中元素,max也在它存在时取。

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
int a[510000],b[510000];//数组范围要注意
const int mod=1e9+7;
int main()
{
    int maxn,n;
    while(~scanf("%d",&n))
    {
        maxn=-mod;
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a[i]);
            a[i]=a[i]-i;
        }
        for(int i=n;i>=1;--i)
        {//从前往后保证i min时取到最大的a max
            a[i]=max(a[i],maxn);
            maxn=max(a[i],maxn);
        }
        for(int i=1;i<=n;++i)
            scanf("%d",&b[i]);
        sort(b+1,b+n+1);
        long long ans=0;
        int j=1;
        maxn=-mod;
        for(int i=n+1;i<=2*n;++i)
        {
            a[i]=max(maxn,a[b[j]]);
            ans+=a[i];
            ans%=mod;
            a[i]-=i;//新取的元素用过后当成已知的元素
            maxn=max(maxn,a[i]);//新取元素用过后当成已知的元素一起更新最大值
            j++;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

ps:
做题时理解错题意了+_+以为是取aj -j和bk 中的max,结果不是【尬

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章