GCD Reduce

Description

You are given a sequence {A1A2, ..., AN}. You task is to change all the element of the sequence to 1 with the following operations (you may need to apply it multiple times):

  • choose two indexes i and j (1 ≤ i < j ≤ N);
  • change both Ai and Aj to gcd(AiAj), where gcd(AiAj) is the greatest common divisor of Ai and Aj.

You do not need to minimize the number of used operations. However, you need to make sure that there are at most 5N operations.

Input

Input will consist of multiple test cases.

The first line of each case contains one integer N (1 ≤ N ≤ 105), indicating the length of the sequence. The second line contains Nintegers, A1A2, ..., AN (1 ≤ Ai ≤ 109).

Output

For each test case, print a line containing the test case number (beginning with 1) followed by one integer M, indicating the number of operations needed. You must assure that M is no larger than 5N. If you cannot find a solution, make M equal to -1 and ignore the following output.

In the next M lines, each contains two integers i and j (1 ≤ i < j ≤ N), indicating an operation, separated by one space.

If there are multiple answers, you can print any of them.

Remember to print a blank line after each case. But extra spaces and blank lines are not allowed.

Sample Input

4
2 2 3 4
4
2 2 2 2

Sample Output

Case 1: 3
1 3
1 2
1 4

Case 2: -1

題意:給出n個數,試着求出這n個數最後的最大公約數是否爲1;若果爲1,那麼給出兩兩匹配的順序(次數不能超出5*n);反之,輸出-1;

我們先判斷n個數的最大公約數是否爲1.即一個數與其他所有數求公約數;看最後是否是1.若果爲1那麼最後輸出的時候。輸出兩遍即可;輸出的次數爲2*n-2;輸出格式不唯一;

標程:

# include <iostream>
# include <cstdio>
using namespace std;

const int maxn = 1e5 + 10;

int a[maxn];

int gcd(int a,int b)
{
    if(b)   return gcd(b,a%b);  //如果b不爲0;
    return a;
}

int main()
{
    int kase=0,n;
    while(~scanf("%d",&n)){
        for(int i = 0; i < n;i++)   scanf("%d",&a[i]);
        int temp = a[0];
        for(int i = 1;i < n;i++)    temp = gcd(temp,a[i]);  //找出所有數的最大公約數;
        printf("Case %d: ",++kase);
        if(temp != 1){
            puts("-1");
            puts("");
        }
        else{
            printf("%d\n",2*n-2);
            for(int i=1;i<n;i++)    printf("1 %d\n",i+1);
            for(int i=1;i<n;i++)    printf("1 %d\n",i+1);
            puts("");
        }
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章