hdu4764 Stone 巴什博弈

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1439    Accepted Submission(s): 1014


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
1 1 30 3 10 2 0 0
 

Sample Output
Jiang Tang Jiang
 


最後肯定剩一個給對方,誰拿誰輸,對N - 1進行巴什博弈,誰先拿完前N - 1也就是剩一個給對方,誰就贏



#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

int n, k;

int main()
{
	while (~scanf("%d%d", &n, &k) && (n || k)) {
		n -= 1;
		if (n % (k + 1) != 0) {
			puts("Tang");
		} else {
			puts("Jiang");
		}
	}
	return 0;
}


發佈了198 篇原創文章 · 獲贊 8 · 訪問量 14萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章