hdu 4405 Aeroplane chess 概率dp

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1499    Accepted Submission(s): 1022


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:  5041 5040 5039 5038 5037 
 

題意:飛行棋,擲骰子決定走的點數,其中還有一些近路,不用花費點數就能通過,求走到n的期望。

思路:把邊記錄下來,邊兩邊的期望值相等,從後向前掃一遍。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
using namespace std;
const int mod=1e9+7;
const int N=100010;
double dp[N];
int edge[N];
int main(){
    int n,m,a,b;
    while(scanf("%d%d",&n,&m),n||m){
        memset(dp,0,sizeof(dp));
        memset(edge,0,sizeof(edge));
        while(m--){
            scanf("%d%d",&a,&b);
            edge[a]=b;
        }
        double p=1.0/6;
        for(int i=n-1;i>=0;i--){
            if(edge[i]){
                dp[i]=dp[edge[i]];
                continue;
            }
            dp[i]=1;
            for(int j=1;j<=6;j++){
                dp[i]+=dp[i+j]*p;
            }
        }

    printf("%.4lf\n",dp[0]);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章