课程练习三-1002-problem B

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = &lt;x1, x2, ..., xm&gt; another sequence Z = &lt;z1, z2, ..., zk&gt; is a subsequence of X if there exists a strictly increasing sequence &lt;i1, i2, ..., ik&gt; of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = &lt;a, b, f, c&gt; is a subsequence of X = &lt;a, b, c, f, b, c&gt; with index sequence &lt;1, 2, 4, 6&gt;. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. <br>The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. <br>
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0

 

题意:

输入两个字符串,求字符串的最大公共子序列的长度。


思路:

DP问题,

将两个字符串中字符str1[i-1]与str2[j-1]位置i,j的相同子串个数记录到dp[i][j],

str1[i]与str2[j]相等,dp[i][j]=dp[i-1][j-1]+1;

否则,dp[i][j]=max(dp[i-1][j],dp[i][j-1]);



AC代码:

#include<iostream>
#include<stdlib.h>
#include<fstream>
#include<string.h>
#include<algorithm>
using namespace std;
char str1[1001],str2[1001];
int dp[1001][1001];


void DP()
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=strlen(str1);i++)
{
for(int j=1;j<=strlen(str2);j++)
{
if(str1[i-1]==str2[j-1])
{
dp[i][j]=dp[i-1][j-1]+1;
}
else
{
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
}
int main()
{
freopen("C:\\Users\\liuzhen\\Desktop\\11.txt","r",stdin);
    while(cin>>str1>>str2)
    {
    DP();
    cout<<dp[strlen(str1)][strlen(str2)]<<endl;
    }
freopen("con","r",stdin);
system("pause");
return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章