poj_Crosses and Crosses_3537

Crosses and Crosses
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 2459   Accepted: 915
Case Time Limit: 2000MS

Description

The game of Crosses and Crosses is played on the field of 1 × n cells. Two players make moves in turn. Each move the player selects any free cell on the field and puts a cross ‘×’ to it. If after the player’s move there are three crosses in a row, he wins.

You are given n. Find out who wins if both players play optimally.

Input

Input file contains one integer number n (3 ≤ n ≤ 2000).

Output

Output ‘1’ if the first player wins, or ‘2’ if the second player does.

Sample Input

#13
#26

Sample Output

#11
#22

考慮到如果畫上一個X,就會有臨近區域不能畫X,也就是下一個人能畫X的區域就變了,那麼問題可以轉換爲誰不能畫X誰就輸了。

#include <iostream>
#include <cstring>
#include <cstdio>
#define N 2010
using namespace std;

int g[N];
int n;

int sg(int num)
{
    //if(num <= 0)
     //   return 0;
    if(g[num] != -1)
        return g[num];
    bool visit[N * 2];
    memset(visit, 0, sizeof(visit));
    visit[sg(num - 3)] = 1;
    visit[sg(num - 4)] = 1;
    for (int i = 0; i <= (num - 5) / 2; i++)
    {
        int t1 = sg(i);
        int t2 = sg(num - 5 - i);
        visit[t1 ^ t2] = 1;
    }
    g[num] = 0;
    while (visit[g[num]])
        g[num] ++;
    return g[num];
}

int main()
{
    memset(g, -1, sizeof(g));
    g[0] = 0;
    g[1] = 1;
    g[2] = 1;
    g[3] = 1;
    g[4] = 2;
    g[5] = 2;
    while (scanf("%d", &n) != EOF)
    {
        if (sg(n) == 0)
            printf("2\n");
        else 
            printf("1\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章