poj_John_3480

John
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2559   Accepted: 1203

Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input

2
3
3 5 1
1
1

Sample Output

John
Brother



拿到最后一个的人输,不是公平组合博弈
考虑个数多于1的巧克力堆数k
k=0时,每堆都是一颗,当堆数为奇数时必败,偶数时必胜
k=1时,必胜
k>=2时, g(x) = 0时,必败, 否则必胜

公平组合博弈
1.两人参与的游戏
2.游戏局面的状态集合是有限的
3.对于同一个局面,两个游戏者的可操作集合完全相同
4.游戏者轮流进行游戏
5.当无法进行操作时,游戏结束,此时不能进行操作的一方算输
6.无论游戏如何进行,总可以在有限步之内结束


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;


int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        int sum = 0;
        int n;
        scanf("%d", &n);
        int res = 0;
        for (int i = 0; i < n; i++)
        {
            int k;
            scanf("%d", &k);
            if (k > 1)
                sum++;
            res ^= k;
        }
        if (sum == 0)
        {
            if(n % 2 == 1)
                printf("Brother\n");
            else 
                printf("John\n");
        }
        else if(sum == 1)
            printf("John\n");
        else 
        {
            if (res == 0)
                printf("Brother\n");
            else 
                printf("John\n");
        }
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章