PAT-A1012 The Best Rank【排序】

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

對於此類題,我一貫喜歡使用結構體+vector的存儲形式,雖然結構體數組也完全是ok的,個人習慣吧 .代碼寫的有點囉嗦,可能是真像老師說的腦子有點直吧

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
struct student{
	string id;                  //學生Id,其實使用int就可以滿足。不過懶得改了
	double a;                   //平均分,不確定是整數,所以用double
	int c;                      //c語言成績
	int m;                      //math成績
	int e;                      //english成績
	int rank[4];                //保存a、c、m、e的rank排名
};
char stu[4]={'A','C','M','E'};
bool sorta(const student s1,const student s2){    下面四個是排序算法
	return s1.a>s2.a;
}
bool sortc(const student s1,const student s2){
	return s1.c>s2.c;
}
bool sortm(const student s1,const student s2){
	return s1.m>s2.m;
}
bool sorte(const student s1,const student s2){
	return s1.e>s2.e;
}
bool sortn(const student s1,const student s2){
	return s1.id<s2.id;
}
void find(vector<student> s,string name){     //採用二分法折半查找
	int left=0,right=s.size()-1;
	int middle=(left+right)/2;
	while(left<=right){ 
		if(s[middle].id<name){                //小了
			left=middle+1;
		}
		else if(s[middle].id>name){           //大了
			right=middle-1;
		} 
		else{                                 //找到了
			int min=10000,index=0;
			for(int i=0;i<4;i++){
				if(s[middle].rank[i]<min){    //找到最優rank,根據權重
					min=s[middle].rank[i];
					index=i;
				}
			}
			printf("%d %c\n",s[middle].rank[index],stu[index]);
			return;
		}
		middle=(left+right)/2;
	}
	printf("N/A\n");
}
int main(){
	vector<student> data;
	int n,z,c,m,e;
	string id;
    scanf("%d %d",&n,&z);
	for(int q=0;q<n;q++){                  //保存數據
		student stu;
		cin>>id;
		scanf("%d %d %d",&c,&m,&e);
		stu.c=c;
		stu.e=e;
		stu.m=m;
		stu.id=id;
		stu.a=(double)(c+m+e)/3;
		data.push_back(stu);
	}
	int size=data.size();
	//對平均分rank排序
	sort(data.begin(),data.end(),sorta);
	data[0].rank[0]=1;                         //這裏注意一點,排名是存在並列關係的,不能
	for(int i=1;i<size;i++){                   //直接根據排名位置給rank複製.,第一個肯定排 
                                               //第一,下面的如果有某個成績和前面的相同,
		if(data[i].a==data[i-1].a){            //排名也必然和前面相同
			data[i].rank[0]=data[i-1].rank[0];
		}else{
			data[i].rank[0]=i+1;
		}
		
	}
    //對c語言成績排序
	sort(data.begin(),data.end(),sortc);
	data[0].rank[1]=1;
	for(int j=1;j<size;j++){
		if(data[j].c==data[j-1].c){
			data[j].rank[1]=data[j-1].rank[1];
		}
		else{
			data[j].rank[1]=j+1;
		}
	}
	//對數學成績排序
	sort(data.begin(),data.end(),sortm);
	data[0].rank[2]=1;
	for(int k=1;k<size;k++){
		if(data[k].m==data[k-1].m){
			data[k].rank[2]=data[k-1].rank[2];
		}
		else{
			data[k].rank[2]=k+1;
		}
	}
	//對英語成績排序
	sort(data.begin(),data.end(),sorte);
	data[0].rank[3]=1;
	for(int t=1;t<size;t++){
		if(data[t].e==data[t-1].e){
			data[t].rank[3]=data[t-1].rank[3];
		}
		else{
			data[t].rank[3]=t+1;
		}
	}
	//對id進行排序,因爲下面要用到二分法
	sort(data.begin(),data.end(),sortn);
	while(z--){
		cin>>id;
		find(data,id);

	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章